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Introduction  
 
The MCS Raptor software provides an advanced PDF Print File support(optional). PDF is the 
standard spool print language of the advertising mail manufacturing industry. The optional MCS 
Raptor PDF print file support uses PDF files that are created by an offline composition tool from 
all the leading professional mail manufacturing document composition software companies such 
as Quadient Inspire TM formerly GMC Software. 
 
MCS Raptor PDF Print File Support option is available on the following printers and platforms: 

� Standalone inkjets 
o MCS Falcon HP thermal technology 
o MCS Osprey Fuji piezo technology  
o MCS Eagle Kyocera piezo technology (up to 34 inches of print) 
o MCS Condor HP process color technology 

� Read and print inserter systems 
� Read and print card attaching systems 

 
Value Proposition and benefits of PDF workflow: 

� The data and layout composition are finalized up-stream. The file will contain all the Job 
Resources prior to the file being brought to the production floor. All document resources 
are embedded into one PDF 

o Data 
o Fonts 
o Graphics 

� The PDF workflow takes the data and composition responsibility out of the hands of the 
operators. The data is locked and cannot be changed creating higher job integrity.  

� Easily integrated into existing workflow using existing Quality Control processes and 
checks. 

� Shop floor ease of use load the file and print creating faster job setups. 
� PDF Raptor jobs can also be used for PerfectMatch jobs on inserters and card attaching 

lines using PDF embedded barcode indexing.  
� Raptor PDF workflow supports Duplex printing. 
� Raptor’s unique PDF workflow allows for a completely random access of PDF pages for 

read and print at speeds over 26,000 pieces per hour. (26000 pcs/hr print rate is highly 
dependent on the PDF page content and page complexity.) 

� PDF object mode workflow allows the contents of a PDF file to be treated as discrete 
objects. This is beneficial when items within the PDF file need to be positionally shifted, 
moved between printhead and or made selectable for spot color when using multiple print 
heads. 
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A) Modes for print page selection: 
Raptor has 4 modes that can be used to achieve the best results for a PDF file print 
application. These modes that are available for PDF workflow are:  
1. Sequential Mode – A mode where records or pages are printed in sequential order. 

An example would be printing addresses on a mailing base.   
a. In Sequential Mode, Raptor loads the PDF file. The PDF file can be accompanied 

with an optional Raptor layout if any of the PDF options need to be adjusted for 
the job.  

b. Printing begins at the start record continues to the end record.  
c. Smaller segments of the PDF file can be printed by changing the start and/or end 

record.  
 

2. PDF Index Mode - A mode for a Read and Print application that would include a 
PDF page number in the barcode data (or a part of it that can be masked off) for 
printing the page specified by this barcode data.. Common applications include 
inserters and card attacher.   

a. In PDF Index Mode, the PDF page number is sent by TCP/IP or serial 
communications prior to each piece being printed.  
 

 
3. PDF Key Mode – A mode that is used for read and print applications using PDF 

files and unique key codes. Because PDF files are not data files, this process ensures 
data integrity when processing a PDF read and print.    

a. In PDF Key Mode, the barcode data (or masked part of the barcode data) must be 
in the Key Field column of the CSV file. The page number that will be printed is 
on the same line as the barcode key. The CSV file can contain additional columns 
and information such as Name, Street, Zip Code, and etc. Raptor supports 
configuration of the Key Field and the Page number field during the job set up. 

b. In PDF Key Mode, the PDF file name (without the .PDF) and the CSV file name 
(without the .CSV) MUST be the same.  When a PDF file is loaded in PDF Key 
Mode, the CSV file is automatically loaded thereby making it impossible to load 
the wrong key file with a PDF file. 
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4. PDF Key Mode with Sort Output -– A mode that is used for read and print 
applications using PDF files and unique key codes and sort data.   

a. This mode is intended for high speed inserter systems where each printed record 
includes Sort Data to be sent to the inserter. In this case, the CSV file should 
include a 3rd column which contains the Sort Data information that is sent.  

b. For applications where Index mode is required with the addition of Sort Data 
Output, the CSV file can contain just the page number and Sort Data Output. In 
this case the Key Field and PDF Key Mode Page # Field would be the same.1 

c. The dialogue box can be found under File > Data File Options, under Sort 
Description. 

 
B) Creating a PDF job in Raptor 

1. In order to print a PDF file a new job must be created. To create a new job click on File 
then click on New Job. 

 

 
 
 
 
 
 
 
 
 
 
 

 
1  This is because in Index mode the key and page number are always the same number. 
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2. The next step is to determine how the data file will be accessed and what fields within the 

data file are to be used. To get to the Data Source and Access Method dialogue box click 
on File then click on Data File Source…  

 

 
 

 
3. The following dialogue box will appear. The Data Source & Access Method dialogue box 

will let you configure the data flow for the PDF print file. 
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4. There are 2 items that need to be defined within the Data Source and Access Method 
dialogue box and they are Data Source and Data Record Access Method. Under Data 
Source there are 3 options: 

a. Data file (local/network file) – this option is used when running in Sequential 
Mode (In Data file source, Data Record Access Method options, Key Field and 
PDF Key Mode Page # Field options are not available.)  

 

 
 

b. TCP/IP (Port: 700)2 –in PDF Index Mode or when running in a Read and 
Print application.  

I. Data Record Access Method should be set to File Index  
II. The TCP/IP connection should be setup in PerfectMatch to send PDF 

page numbers prior to each piece being printed. For example, a Read and 
Print application could include a PDF page number in the barcode data (or 
a part of it that can be masked off) for printing the page indicated by this 
barcode data.  

 

 
 
 
 
 
 

 
2 The TCP/IP Port number is defined in Raptor’s configuration file. 
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c. TCP/IP (Port: 700) – in PDF Key Mode.  

I. Data Record Access Method should be set to File Key  
II. Key Field should be set to the CSV field which contains the key. PDF Key 

Mode Page # Field should be set to the CSV field of the PDF page 
number. As with Index mode, PerfectMatch requires that TCP/IP be 
selected.  

III. If using PDF Key mode using PDF bookmarks the Key Field and PDF 
Key Mode Page # Field are ignored. 

IV. The barcode data (or masked part of the barcode data) must be in the Key 
Field column of the CSV file. The page number that will be printed will be 
on the same line as the barcode key.  

 

 
 

d. Serial (COM1)3 –in PDF Index Mode or when running in a Read and Print 
application.  

I. Data Record Access Method should be set to File Index  
II. The TCP/IP connection should be setup to send PDF page numbers prior 

to each piece being printed. For example, a Read and Print application 
could include a PDF page number in the barcode data (or a part of it that 
can be masked off) for printing the page indicated by this barcode data.  

 

 

 
3 The Serial COM port is defined in Raptor’s configuration file. 
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e. Serial (COM1) – in PDF Key Mode.  

I. Data Record Access Method should be set to File Key  
II. Key Field should be set to the CSV field which contains the key. PDF Key 

Mode Page # Field should be set to the CSV field of the PDF page 
number. As with Index mode, PerfectMatch requires that TCP/IP be 
selected.  

III. The barcode data (or masked part of the barcode data) must be in the Key 
Field column of the CSV file. The page number that will be printed will be 
on the same line as the barcode key.  

IV. Click OK when done 
 

 
 

5. Data File Options 
a. Click on File > Data File Options 
b. Default file type is CSV. If CSV is not selected, select it. 
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6. With .csv only jobs the Define File Filters button will open the Datafile Filter Settings 
dialogue box where the filters can be setup to reduce the datafile records that are loaded. 
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7. PDF Options  
a. Select File > PDF Options 
 
b. This section provides information about the PDF file. 

i. File Path and Name 
ii. Number of Pages 
iii. Width 
iv. Height 

 
c. Allows for physical adjustment of the PDF form. 

i. Rotation 
ii. Layout Offset 

 
d. Updating Layout Page Size on PDF File Load 

 
e. Gamma & Dither options for Monochrome (single drop) Printers only  

i. Gamma Correction  
ii. Threshold 
iii. For Dither #1(Slower) 
 

f. PDF Index Mode 
 

g. Password Required to open PDF file 
 

h. Save settings and use them for new layouts 
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8. Print Set Up 
a. Select File > Print Set Up… 
b. In print set up paper size, orientation etc. can be selected 
c. Please refer to the Raptor Operator manual for full description of available 

options. 
 

 
 

d. Grayscale; these features are used with Multi Drop (40Khz) Printers. When 
Grayscale is enabled, the setting in the Grayscale tab will override the settings in 
the PDF Options and gray out the values. 
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C) View > Print Options 
Provides functionality for 

1. If start and end record is changed that would cause for duplicates to be printed 
2. Automatically saving print parameters 
3. Warn if job has no unprinted pieces 
4. Duplicate checking 
5. Layout Length and Piece Length checking 
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D) Guidelines for file naming 
1. The PDF and CSV files that are going to be used to run the print job have to have the 

same name, only the file extension will be different. By doing this the Raptor software 
will be able to associate the PDF with the corresponding CSV files on file load. 

a. Example: 001166068.pdf and 001166068.csv  
2. The PDF file the file to be used along with the corresponding CSV file (if there is one) 

must be saved to the same folder on the Computer. 
 
 
 
 
D) Opening a PDF File 

1. File > Open PDF File… 
2. The following window appears. Navigate to the directory where the file is saved. 
3. If a corresponding CSV file is being used the CSV file will be loaded at the same time as 

the PDF file. 
a. Open PDF dialogue screen 
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b. Once loaded the following should appear.  If the PDF contains PDF Key mode 
bookmarks the list of bookmarks and page numbers will also appear. 

 
 

c. If there is an associated CSV file the Data tab will contain the fields within the 
CSV file and the appropriate data can be seen, as shown above 

 
E)  Guidelines for splitting large PDF files using GMC 

The reason for being able to slit a large PDF file into multiple smaller files is so that 
workflow can be spread out across multiple systems on the production floor. The process 
described here allows for this to be done while maintaining data integrity across the file 
by using a CSV index file.  If bookmarks are being used for PDF Key mode PDF files 
can simply be split and the bookmarks will remain matched to the pages in the split file. 
 
In order to accomplish the splitting of a large file GMC needs to create and export 2 files 
one being the PDF the other being a CSV index file, the export needs to be part of the 
available features of GMC. 
 
Using standard GMC features: 
For example if we need to split a 1M piece job into (10) 100,000-page PDF files.  GMC 
would produce 2 files one a PDF the other a CSV index file for each of the (10) 100,000 
records files, and each of the files will have the same name but each will have a different 
file extension one being .pdf the other .csv. 
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The assumption would be that when we would open say the third split file which 
represents pieces 300,001 through 400,000.  GMC would have generated the following 2 
files: 
1MJob_300001_to_400000.pdf  
1MJob_300001_to_400000.csv 
 
The PDF file has pages 1 through 100,000 but are actually pages 300,001 to 400,000 of 
the 1M piece job. 
 
So, when we run PerfectMatch we will scan a symbol which decodes to 350,412.  The 
CSV file would tell us which page to print from our split file: 
 
CSV File 1MJob_300001_to_400000.csv will contain: (tray break is optional) 
Unique ID, Page Number, Tray break, CR, LF 
 

 
 
There can be other fields in the file, but we would need to know all 3 field 
positions/names within the CSV file. 
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F) PDF Object Mode (Composition workflow) 
 

1. Workflow 
PDF object mode allows the contents of a PDF file to be treated as discrete objects. In doing this, 
the operator has the ability to use Raptor as a composition tool using a PDF file. This gives the 
operator the ability to adjust portions of the PDF page within the print head or between print 
heads on a multiple print head system it also allows the operator to apply spot color to select 
areas of the PDF file. 
 
As part of the workflow it is recommended that a composite layout be created prior to the PDF 
image being manipulated, in doing this the operator will have the a visual of what the final 
product is to look like. 
 
It is recommended that a template in the layout software be created which indicates the vertical 
print height of the intended print technology. For example, if the printer that is to be used is a 
Falcon, the template should include dotted lines running left to right spaced ½ apart inch which 
indicate the individual pen boundaries. Then the text to be printed can be setup and previewed to 
show that text doesn’t overlap pen boundaries which might cause poor print quality. 
 
In order to use PDF Object mode, click on the Layout tab and then click on New Job from the 
File Menu 
 

 
The following screen will appear 
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Under New select PDF Object 
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The following screen will appear. Select the PDF file that needs to be modified from the folder 
and click on open. 
 

 
 
Once the file is selected Raptor will open the editor window. The following screen will be 
opened showing the PDF file content and the selection tool in the upper left of the screen.  
If the PDF image is larger than the window, click on the Fit Image button on the upper left or use 
the slider bar to shrink the image. 
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Drag the selection window over the area of interest that needs to be modified. If it is the address 
block, it is recommended that the selection box is cropped as far to the margin as possible (as 
shown below) so that the larger addresses are not cropped when printed. Click OK. 
 

 
 
When OK is clicked Raptor will go from editor to composition mode.  
 
Move the selected data to the appropriate position in the layout. 
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If another portion of the PDF image need to be manipulated, click again on New > PDF Object 
and do the process again until the new layout is created. 
 

 
 
Position the selected item in the correct position. 



 

Copyright © 2019 MCS. All Rights Reserved  Page 21 

  
 
 
If the system is configured with multiple print heads such as a Falcon configuration the layout 
would look like this.  

 
 
Once the layout is completed click on the Job tab and the print process can be start. 
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2. Spot color setup  
In Spot Color Mode, a Print Bar is selected, its color is changed to the color of the ink being used 
by that printer. Every Object which is attached to that print bar is shown in the color of the print 
bar.  
 

 
Example of 1 printhead configuration 
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Example of 2 printhead configuration 
 
To add a spot color, right click on the print bar on the left. If it is a multiple print head system, 
both print head will be shown first select the print head you want to set spot color for then click 
on Edit Spot Color. 
 
The following screen will be displayed. Select the color to be used and click Ok. 
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Once the spot color is selected the Raptor Layout screen will reflect the change. 

 
 
Once the layout is completed click on the Job tab and the print process can be start. 
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G) GrayScale Tutorial 
This document illustrates the use of Grayscale settings tab in Raptor when printing with a 
grayscale enabled printer. The settings can be changed by selecting file, print setup, and selecting 
the Grayscale tab. 

 
The pictures which follow are scans of actual printed documents with different settings applied 
in the Grayscale tab. 
The first image sample comes from an image which has poor dynamic range and contrast. 
To the right of each image is a list with the settings as applied to print the image. 
Higher levels of Black Level shifts dark grays toward black 
Higher levels of White Level shifts light grays toward white 
Lower levels of Gamma Correction shift mid grays lighter 
 
Note:  When using these settings, please leave the Pixels1 and Pixel 2 thresholds at their default 
values, as shown above. 
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Black Level:   0 
White Level:   0 
Gamma Correction: 1 

Black Level:   0 
White Level:   25 
Gamma Correction: 1 

Black Level:   25 
White Level:   0 
Gamma Correction: 1 

ORIGINAL IMAGE 
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Black Level:   25 
White Level:   25 
Gamma Correction: 1 

Black Level:   0 
White Level:   50 
Gamma Correction: 1 

Black Level:   50 
White Level:   0 
Gamma Correction: 1 
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Black Level:   50 
White Level:   50 
Gamma Correction: 1 

Black Level:   50 
White Level:   50 
Gamma Correction: 0.7 

Black Level:   50 
White Level:   50 
Gamma Correction: 0.5 

OPTIMIZED IMAGE 


